Zuletzt bearbeitet vor 5 Monaten
von Anonymer Benutzer

IPv6 auf VDSL und Swisscom Fiber Anschlüssen mit PPPoE

Grundsätzliches

Bei einem PPPoE Anschluss erhält ihr Router mit SLAAC eine IPv6 WAN Adresse und kann über DHCPv6 eine /48 PD anfordern.


Config Beispiel anhand von MikroTik:

PPP

Auf dem PPP Profil IPv6 aktivieren:

 /ppp profile set default use-ipv6=yes



IPv6

DHCP Client

IPv6 DHCP Client aktivieren, Prefix requesten und Pool definieren:

/ipv6 dhcp-client enable

/ipv6 dhcp-client set interface=sfp-sfpplus1-wan-VLAN11-pppoe request=prefix pool-name=ipv6-pool pool-prefix-length=64 use-peer-dns=yes add-default-route=yes

Der Pool wird dynamisch generiert und darf nicht manuell unter /ipv6 pool erfasst werden.

DHCP Server

IPv6 DHCP Server für LAN:

/ipv6 dhcp-server enable

/ipv6 dhcp-server set name=server-lan-ipv6 interface=bridge-lan-private address-pool=ipv6-pool

Firewall

IPv6 Firewall DHCP Traffic erlauben:

/ipv6 firewall filter set chain=input src-address=fe80::/10 protocol=udp dst-port=546 in-interface=sfp-sfpplus1-wan-VLANL11-pppoe action=accept





(Optional) WAN Address

Da MikroTik auf dem PPP Interface kein SLAAC macht muss manuell eine IP aus dem /64 auf dem WAN zugewiesen werden wenn der MikroTik selber auf dem WAN erreichbar sein soll.

Seems to be fixed in RouterOS v7.X.X